Matomo Update 4.1 – Internal Server Error!

Vor ein paar Tagen startete ich die Aktualisierung auf die neue Version Matomo 4.1. Zunächst sah alles gut aus. Als ich dann das Matomo-Verzeichnis aufrief – kam die berüchtigte Fehlermeldung: Internal Server Error 500.

Da nichts mehr ging, prüfte ich zunächst die PHP Einstellung. Die war zwar nicht topaktuell aber mit PHP 7.3 nicht unbedingt fehlerverdächtig.

Auf der Suche nach Lösungen stieß ich auf Gerhard Kerners Technikblog, der empfahl, in der Datenbank die Version auf die Vorgängerstufe herunterzusetzen. In der Tabelle piwik***_option reduzierte ich die Version. Ein neuer Startversuch schlug genauso fehl.

Die einzige Lösung war hier das manuelle Update. Die heruntergeladene Version Matomo 4.1 habe ich via FTP (im binären Modus) in mein Matomoverzeichnis hochgeladen. Beim neuerlichen Aufruf von Matomo kam nun wieder die vertraute Rückmeldung, dass die Datenbank noch aktualisiert werden müsse. Gelesen, getan und die neue Version läuft wieder wie am Schnürchen.

Ich habe die Serverlogs nicht geprüft, ich vermute aber, dass das Plugin Bot Tracker den Fehler verursacht hatte. Beim neuerlichen Einloggen kam die Warnung, dass das Plugin mit dieser Version nicht kompatibel sei. Ich hatte es zwar deaktiviert, nun aber völlig gelöscht.

Also – wenn das (halb-)automatische Update nicht klappt, kommt man mit dem manuellen Update ohne Datenverlust ans Ziel.

Nachtrag vom 11.02.2021: auch das Update von früheren Versionen als 4.1.0 auf 4.1.1 erzeugt einen Servererror 500 bei mir. Auch hier hat das manuelle Nachinstallieren geholfen. Das Update von 4.1.0 auf 4.1.1 líef dagegen reibungslos.